webpackをアップデートしたらgulpfile.jsにautoprefixerの設定書いてるとエラー出るようになったのでpackage.jsonへ移動する

  • 2019.06.17
  • 2019.07.31
  • coding
webpackをアップデートしたらgulpfile.jsにautoprefixerの設定書いてるとエラー出るようになったのでpackage.jsonへ移動する

webpackをアップデートしたらgulpfile.jsにautoprefixerの設定書いてるとエラー出るようになったのでpackage.jsonへ移動する

webpackをアップデートしたらgulpfile.jsにautoprefixerの設定書いてるとエラー出るようになったのでpackage.jsonへ移動する
最終更新日:2019.07.31

webpackを入れ直してコンパイルするとautoprefixerでエラーが出るようになったので解決方法です。

エラー内容

Replace Autoprefixer browsers option to Browserslist config.
Use browserslist key in package.json or .browserslistrc file.

Using browsers option cause some error. Browserslist config
can be used for Babel, Autoprefixer, postcss-normalize and other tools.

If you really need to use option, rename it to overrideBrowserslist.

Learn more at:
https://github.com/browserslist/browserslist#readme
https://twitter.com/browserslist

翻訳すると…
AutoprefixerブラウザオプションをBrowserslist設定に置き換えます。
package.jsonまたは.browserslistrcファイルでbrowserslistキーを使用してください。

ブラウザオプションを使用するとエラーが発生します。ブラウザリスト設定
Babel、Autoprefixer、postcss-normalize、その他のツールに使えます。

あなたが本当にoptionを使う必要があるなら、overrideBrowserslistにそれを改名してください。

なこ
???ようわからんけどpackage.jsonに移動させたらいいんだな!

解決方法

gulpfile.jsに書いてあるautoprefixerの設定をpackage.jsonに移動します。
例えばgulpfile.js


  .pipe(autoprefixer({
      browsers: ['last 2 version', 'iOS >= 8.1', 'Android >= 4.0'],
      cascade: false
    }))

webpackをアップデートしたらgulpfile.jsにautoprefixerの設定書いてるとエラー出るようになったのでpackage.jsonへ移動する

移動するよ

package.json
webpackをアップデートしたらgulpfile.jsにautoprefixerの設定書いてるとエラー出るようになったのでpackage.jsonへ移動する

“browserslist”: [
“last 2 versions”,
“iOS 8.1”,
“Android 4.0”
]

一番下に挿入します。

これで再度runすればエラーなくコンパイルできるハズです!