Gulp v3系からGulp v4系へ移行する時 一番簡単な方法

  • NEW
  • 2019.06.17
  • 2019.06.17
  • coding
Gulp v3系からGulp v4系へ移行する時 一番簡単な方法

Gulp v3系からGulp v4系へ移行する時 一番簡単な方法

Gulp v3系からGulp v4系へ移行する時 一番簡単な方法
最終更新日:2019.06.17

Gulp v3系からGulp v4系へ移行するとエラーがでてコンパイルできなくなります。
それはgulpfile.jsの書き方が変わった為です。

エラー内容

例えばこんなエラーが表示されます。

throw new errors.AssertionError({
AssertionError [ERR_ASSERTION]: Task function must be specified

解決方法

メジャーアップデートして動かなくなった時…いろいろと解決法はありますが、
gulpfile.jsはこの箇所だけ書き換えたら動きます!!

gulp.watch(dev_dir + ‘/sass/*.scss’, [‘sass’], function(event) {});
gulp.task(‘default’, [‘watch’]);

Gulp v3系からGulp v4系へ移行する時 一番簡単な方法

gulp.watch(dev_dir + ‘/sass/*.scss’, gulp.task(‘sass’), function(event) {});
gulp.task(‘default’, gulp.task(‘watch’));

青枠の箇所に変更するだけです!